aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-lz4/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py-lz4/APKBUILD')
-rw-r--r--community/py-lz4/APKBUILD26
1 files changed, 10 insertions, 16 deletions
diff --git a/community/py-lz4/APKBUILD b/community/py-lz4/APKBUILD
index b1991324b0..ba873dcb17 100644
--- a/community/py-lz4/APKBUILD
+++ b/community/py-lz4/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=py-lz4
-pkgver=0.11.1
+pkgver=0.13.0
_pkgname=${pkgname#py-}
pkgrel=0
pkgdesc="LZ4 Bindings for Python"
@@ -16,16 +16,18 @@ if [ "$CARCH" = "s390x" ]; then
options="!check"
fi
subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2 $pkgname-tests:_tests:noarch"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
- disable-failing-test.patch
- "
-
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
cd "$builddir"
- python2 setup.py build || return 1
- python3 setup.py build || return 1
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python2 setup.py test
}
package() {
@@ -58,12 +60,4 @@ _tests() {
mv "$builddir"/tests "$subpkgdir"/usr/share/$pkgname
}
-check() {
- cd "$builddir"
- # issue opened for failing test:
- # https://github.com/python-lz4/python-lz4/issues/19
- python setup.py test
-}
-
-sha512sums="7b1c952dccb1fc1436396f1642db91d63fa11aaf992d7adf72891bfa5ad83c767e96c2d9a31bf444b1eda74430e456e228dfdea291ee8f5c471c13f146988671 lz4-0.11.1.tar.gz
-6fb99988e604a3a2f72d6297d2c0596586bdf7cc66c740061c362502de04a2fe9f814708c5722874b45df6cddd14303a3920de1249ca3b98a5a8eb19bb981a04 disable-failing-test.patch"
+sha512sums="0175838981e21301c20b64e02959c73723d9de629fb8dc10ea745b0ef5a5de95d37f5abe1e7b2c104658b3ebd66a84ef948b7ff3e2eb556162e9e0e5fbd4c9ff lz4-0.13.0.tar.gz"