aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-lz4/system-libs.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/py-lz4/system-libs.patch')
-rw-r--r--community/py-lz4/system-libs.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/community/py-lz4/system-libs.patch b/community/py-lz4/system-libs.patch
new file mode 100644
index 0000000000..e746ac0241
--- /dev/null
+++ b/community/py-lz4/system-libs.patch
@@ -0,0 +1,26 @@
+diff --git a/setup.py b/setup.py
+index 9fa3131..ad2f6a3 100644
+--- a/setup.py
++++ b/setup.py
+@@ -10,8 +10,8 @@ PY3C_REQUIRED_VERSION = '>= 1.0'
+
+ # Check to see if we have a lz4 and py3c libraries installed on the system, and
+ # of suitable versions, and use if so. If not, we'll use the bundled libraries.
+-liblz4_found = False
++liblz4_found = True
+ py3c_found = False
+ try:
+ from pkgconfig import installed as pkgconfig_installed
+ from pkgconfig import cflags as pkgconfig_cflags
+@@ -95,9 +95,7 @@ if compiler == 'msvc':
+ extra_compile_args = ['/Ot', '/Wall', '/wd4711', '/wd4820']
+ elif compiler in ('unix', 'mingw32'):
+ if liblz4_found:
+- extra_link_args.append(pkgconfig_libs('liblz4'))
+- if pkgconfig_cflags('liblz4'):
+- extra_compile_args.append(pkgconfig_cflags('liblz4'))
++ extra_link_args.append('-llz4')
+ else:
+ extra_compile_args = [
+ '-O3',
+