aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-lz4/system-lz4.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/py-lz4/system-lz4.patch')
-rw-r--r--community/py-lz4/system-lz4.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/community/py-lz4/system-lz4.patch b/community/py-lz4/system-lz4.patch
new file mode 100644
index 0000000000..7a7ef828c7
--- /dev/null
+++ b/community/py-lz4/system-lz4.patch
@@ -0,0 +1,27 @@
+diff --git a/setup.py b/setup.py
+index 19b50f0..9302e4d 100644
+--- a/setup.py
++++ b/setup.py
+@@ -50,6 +50,8 @@ lz4frame_sources = [
+ 'lz4/frame/_frame.c'
+ ]
+
++liblz4_found = True
++
+ if liblz4_found is True:
+ libraries.append('lz4')
+ else:
+@@ -86,9 +88,10 @@ if compiler == 'msvc':
+ extra_compile_args = ['/Ot', '/Wall']
+ elif compiler in ('unix', 'mingw32'):
+ if liblz4_found:
+- extra_link_args.append(pkgconfig.libs('liblz4'))
+- if pkgconfig.cflags('liblz4'):
+- extra_compile_args.append(pkgconfig.cflags('liblz4'))
++ extra_link_args.append('-llz4')
++# extra_link_args.append(pkgconfig.libs('liblz4'))
++# if pkgconfig.cflags('liblz4'):
++# extra_compile_args.append(pkgconfig.cflags('liblz4'))
+ else:
+ extra_compile_args = [
+ '-O3',