aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-numpy/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py-numpy/APKBUILD')
-rw-r--r--community/py-numpy/APKBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/community/py-numpy/APKBUILD b/community/py-numpy/APKBUILD
index 431643fc89..002dd8d4b3 100644
--- a/community/py-numpy/APKBUILD
+++ b/community/py-numpy/APKBUILD
@@ -5,11 +5,11 @@
pkgname=py-numpy
_pkgname=numpy
pkgver=1.16.4
-pkgrel=0
+pkgrel=1
pkgdesc="Scientific tools for Python"
-url="http://numpy.scipy.org/"
+url="https://www.numpy.org/"
arch="all"
-license="BSD"
+license="BSD-3-Clause"
options="!check"
makedepends="python2-dev py-setuptools python3-dev
cython openblas-dev>=0.3.0 gfortran py-nose"
@@ -33,14 +33,11 @@ build() {
export Atlas=None
LDFLAGS="$LDFLAGS -shared"
- cd "$builddir"
python2 setup.py build config_fc --fcompiler=gnu95
python3 setup.py build config_fc --fcompiler=gnu95
}
package() {
- cd "$builddir"
-
local python; for python in python2 python3; do
$python setup.py install --prefix=/usr --root="$pkgdir" \
config_fc --fcompiler=gnu95