aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-skywriter-hat/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py-skywriter-hat/APKBUILD')
-rw-r--r--community/py-skywriter-hat/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/py-skywriter-hat/APKBUILD b/community/py-skywriter-hat/APKBUILD
new file mode 100644
index 0000000000..204cb87a4f
--- /dev/null
+++ b/community/py-skywriter-hat/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
+# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
+pkgname=py-skywriter-hat
+pkgver=0.0.6
+pkgrel=0
+pkgdesc="Python libraries for the Pimoroni Skywriter board"
+url="https://github.com/pimoroni/skywriter-hat"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev"
+install=""
+subpackages=""
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/pimoroni/${pkgname#py-}/archive/v${pkgver}.tar.gz"
+builddir=${srcdir}/${pkgname#py-}-${pkgver}
+build() {
+
+ cd "$builddir/python/library"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$builddir/python/library"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="03ef9d123c0add41b9130b99de5d6a51 py-skywriter-hat-0.0.6.tar.gz"
+sha256sums="7adf2ca2ed2d7166888e6023f2c938c556f4e9b16ac12120f017176a7b70e73f py-skywriter-hat-0.0.6.tar.gz"
+sha512sums="57536ca307ed13e36c50b5c32d4d550057dc6090660886916c34860720ef5011ff17fece8012f7ba4b1be065774e45d049773f4dedce9a1eeb39b6c66719f683 py-skywriter-hat-0.0.6.tar.gz"