aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-zipstream
diff options
context:
space:
mode:
Diffstat (limited to 'community/py-zipstream')
-rw-r--r--community/py-zipstream/APKBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/community/py-zipstream/APKBUILD b/community/py-zipstream/APKBUILD
index 9657ed63f0..43001ad234 100644
--- a/community/py-zipstream/APKBUILD
+++ b/community/py-zipstream/APKBUILD
@@ -2,22 +2,28 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=py-zipstream
_pkgname=python-zipstream
-pkgver="1.1.4"
-pkgrel=0
+pkgver=1.1.4
+pkgrel=1
pkgdesc="Like Python's ZipFile module, except it works as a generator that provides the file in many small chunks."
url="https://github.com/allanlei/python-zipstream"
arch="noarch"
license="GPL3"
-depends=""
makedepends="python2-dev python3-dev py-setuptools"
-install=""
subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2"
source="$pkgname-$pkgver.tar.gz::https://github.com/allanlei/$_pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
+
+check() {
+ cd "$builddir"
+ python2 setup.py check
+ python3 setup.py check
+}
+
+
build() {
cd "$builddir"
- python2 setup.py build || return 1
- python3 setup.py build || return 1
+ python2 setup.py build
+ python3 setup.py build
}
package() {