aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-zipstream
diff options
context:
space:
mode:
Diffstat (limited to 'community/py-zipstream')
-rw-r--r--community/py-zipstream/APKBUILD52
1 files changed, 0 insertions, 52 deletions
diff --git a/community/py-zipstream/APKBUILD b/community/py-zipstream/APKBUILD
deleted file mode 100644
index 78bd4f86e0..0000000000
--- a/community/py-zipstream/APKBUILD
+++ /dev/null
@@ -1,52 +0,0 @@
-# Contributor: Francesco Colista <fcolista@alpinelinux.org>
-# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=py-zipstream
-_pkgname=python-zipstream
-pkgver=1.1.4
-pkgrel=2
-pkgdesc="Like Python's ZipFile module, except it works as a generator that provides the file in many small chunks."
-url="https://github.com/allanlei/python-zipstream"
-arch="noarch"
-license="GPL-3.0"
-makedepends="python2-dev python3-dev py-setuptools"
-subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2"
-source="$pkgname-$pkgver.tar.gz::https://github.com/allanlei/$_pkgname/archive/v$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
-
-check() {
- cd "$builddir"
- python2 setup.py check
- python3 setup.py check
-}
-
-
-build() {
- cd "$builddir"
- python2 setup.py build
- python3 setup.py build
-}
-
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py() {
- local python=$1
- pkgdesc="$pkgdesc - $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-_py2() {
- _py python2
- replaces="$pkgname"
-}
-
-_py3() {
- _py python3
-}
-
-md5sums="18e2344412f3c46426e5df6cece33d6b py-zipstream-1.1.4.tar.gz"
-sha256sums="32a7a4bdb786914445589595273beffbbf9b6a0a3a3dc2cf19ea96114bd2abd7 py-zipstream-1.1.4.tar.gz"
-sha512sums="722c1d7db91dc47064fc51f1182417f46923b8f42a56e854f1fa125eaccfc7f86d3deab71709226a798a1caf5a84a8a7fa7d3564065ab91afbad434ed787ce32 py-zipstream-1.1.4.tar.gz"