aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-aiohttp
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-aiohttp')
-rw-r--r--community/py3-aiohttp/APKBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/community/py3-aiohttp/APKBUILD b/community/py3-aiohttp/APKBUILD
index 1c476171bf..fe203ae40c 100644
--- a/community/py3-aiohttp/APKBUILD
+++ b/community/py3-aiohttp/APKBUILD
@@ -19,6 +19,13 @@ check() {
python3 setup.py check
}
+prepare() {
+ default_prepare
+ # Workaround to remove x86_64 .so file that is shipped in source
+ # and make strip fails in arches != from x86_64
+ rm "$srcdir"/aiohttp-2.3.1/aiohttp/_http_parser.cpython-36m-x86_64-linux-gnu.so
+}
+
build() {
cd "$builddir"
python3 setup.py build