aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-augeas/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-augeas/APKBUILD')
-rw-r--r--community/py3-augeas/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/py3-augeas/APKBUILD b/community/py3-augeas/APKBUILD
new file mode 100644
index 0000000000..5446adcb9b
--- /dev/null
+++ b/community/py3-augeas/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py3-augeas
+_pkgname=python-augeas
+pkgver=1.0.3
+pkgrel=4
+pkgdesc="Pure python bindings for augeas"
+url="https://pypi.python.org/pypi/python-augeas"
+arch="noarch"
+license="LGPL-2.1-or-later"
+depends="augeas-libs py3-cffi python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ dlopen-libc-explicitly.patch
+ "
+builddir="$srcdir"/$_pkgname-$pkgver
+
+replaces=py-augeas # Backwards compatibility
+provides=py-augeas=$pkgver-r$pkgrel # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"/test
+ python3 test_augeas.py
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="737b41e7bb438d80da75b55714c3f0b1706a4b2cacddd20fadf855bc3044e532f4079319b3775032e6f6009cf7f282af33fdf583332772b443a6c2d4925639fa python-augeas-1.0.3.tar.gz
+938e1a28d70c8ffbf62fd2936a57276603487608fbb3e23bf3a59a4f655e7d875ad51e6506acbddf4eea27a433fe3c9c35da3e00be04c8c866a5a966cdf3b161 dlopen-libc-explicitly.patch"