aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-configshell
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-configshell')
-rw-r--r--community/py3-configshell/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/community/py3-configshell/APKBUILD b/community/py3-configshell/APKBUILD
new file mode 100644
index 0000000000..d747f5ba56
--- /dev/null
+++ b/community/py3-configshell/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=py3-configshell
+_pkgname=configshell
+pkgver=1.1.26
+pkgrel=0
+pkgdesc="Python library that provides a framework for building simple but nice CLI-based applications"
+url="https://github.com/agrover/configshell-fb"
+arch="noarch"
+license="Apache-2.0"
+depends="python3 py3-six py3-urwid py3-parsing"
+makedepends="py3-setuptools"
+options="!check" # no test suite
+source="$_pkgname-fb-$pkgver.tar.gz::https://github.com/agrover/configshell-fb/archive/v$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-fb-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="25e5b4ee812a51c99eed4d039ac8bab883218a674ff27f9eee4604d133b592574f4829ead9cb1aba4d2aca873f5414ad4ca55979c6d4eadaa9a802b1d563494d configshell-fb-1.1.26.tar.gz"