aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-core-api
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-core-api')
-rw-r--r--community/py3-core-api/APKBUILD32
-rw-r--r--community/py3-core-api/no-flake8.patch11
2 files changed, 43 insertions, 0 deletions
diff --git a/community/py3-core-api/APKBUILD b/community/py3-core-api/APKBUILD
new file mode 100644
index 0000000000..ecd501aa31
--- /dev/null
+++ b/community/py3-core-api/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=py3-core-api
+_pkgname=python-client
+pkgver=2.3.3
+pkgrel=5
+pkgdesc="Python client library for Core API"
+url="https://github.com/core-api/python-client"
+arch="noarch"
+license="BSD-2-Clause"
+depends="py3-coreschema py3-itypes py3-requests py3-uritemplate"
+makedepends="py3-setuptools"
+checkdepends="py3-coverage py3-pytest py3-core-api"
+source="$pkgname-$pkgver.tar.gz::https://github.com/core-api/python-client/archive/$pkgver.tar.gz
+ no-flake8.patch
+ "
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py --quiet build
+}
+
+check() {
+ python3 runtests
+}
+
+package() {
+ python3 setup.py --quiet install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="aeae3ace84c0ce61552236b83db28e47492f5ac17a0e216e1a8eeddaf67270b94127f7a40f8a37cc5051abe097555adfd690a7e6c8801524ca77c916bd451ab8 py3-core-api-2.3.3.tar.gz
+46f6ec6ef970094d41cb9d61c7225c19ea37b19bcba6287c7c8f26a1b11da5bd34a60cd6582436f0450cc5c8f616d499dd2ceb8fa2d6e6042c39715e68343310 no-flake8.patch"
diff --git a/community/py3-core-api/no-flake8.patch b/community/py3-core-api/no-flake8.patch
new file mode 100644
index 0000000000..39d8152eef
--- /dev/null
+++ b/community/py3-core-api/no-flake8.patch
@@ -0,0 +1,11 @@
+diff --git a/runtests b/runtests
+index 8b260d9..dba9456 100755
+--- a/runtests
++++ b/runtests
+@@ -86,5 +86,4 @@ if __name__ == "__main__":
+ cov.start()
+ exit_on_failure(pytest.main(pytest_args))
+ cov.stop()
+- exit_on_failure(flake8_main(FLAKE8_ARGS))
+ report_coverage(cov)
+