aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-flask-script/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-flask-script/APKBUILD')
-rw-r--r--community/py3-flask-script/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/py3-flask-script/APKBUILD b/community/py3-flask-script/APKBUILD
new file mode 100644
index 0000000000..2626cf145c
--- /dev/null
+++ b/community/py3-flask-script/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer:
+pkgname=py3-flask-script
+_pkgname=Flask-Script
+pkgver=2.0.6
+pkgrel=1
+pkgdesc="Flask scripting support"
+url="https://pypi.python.org/pypi/Flask-Script"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3 py3-flask"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+replaces="py-flask-script" # Backwards compatibility
+provides="py-flask-script=$pkgver-r$pkgrel" # Backwards compatibility
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="03c51213be8e2b86f1f4450565cf4d7e3d9d7257ac017bd53830be57620d581f43bcfe959ef7b621af722c688c56495229aad3dd9654c8a8a5905db0105275fc Flask-Script-2.0.6.tar.gz"