aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-jsonschema
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-jsonschema')
-rw-r--r--community/py3-jsonschema/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/py3-jsonschema/APKBUILD b/community/py3-jsonschema/APKBUILD
new file mode 100644
index 0000000000..add1e9ae3f
--- /dev/null
+++ b/community/py3-jsonschema/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py3-jsonschema
+_pkgname=jsonschema
+pkgver=2.5.1
+pkgrel=2
+pkgdesc="An implementation of JSON Schema validation for Python"
+url="http://github.com/Julian/jsonschema"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="python3-dev py-setuptools"
+install=""
+subpackages="$pkgname-doc"
+replaces="py-jsonschema"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --root="$pkgdir/" --optimize=1
+ install -D -m644 json/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
+
+md5sums="374e848fdb69a3ce8b7e778b47c30640 jsonschema-2.5.1.tar.gz"
+sha256sums="36673ac378feed3daa5956276a829699056523d7961027911f064b52255ead41 jsonschema-2.5.1.tar.gz"
+sha512sums="9e8f6ce16504b7ae7ef1ceb44ecb07eab85923e40967bd8e502b9fa779e772b547db90f56ca951d06591b951e7240db1071e909ac75543d42f6f2495f6de3298 jsonschema-2.5.1.tar.gz"