aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-ndg_httpsclient
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-ndg_httpsclient')
-rw-r--r--community/py3-ndg_httpsclient/APKBUILD7
1 files changed, 2 insertions, 5 deletions
diff --git a/community/py3-ndg_httpsclient/APKBUILD b/community/py3-ndg_httpsclient/APKBUILD
index 02394c3342..5d3871673b 100644
--- a/community/py3-ndg_httpsclient/APKBUILD
+++ b/community/py3-ndg_httpsclient/APKBUILD
@@ -7,23 +7,20 @@ pkgrel=1
pkgdesc="HTTPS client implementation for httplib and urllib2 based on PyOpenSSL"
url="https://github.com/cedadev/ndg_httpsclient"
arch="noarch"
-license="BSD"
+license="BSD-2-Clause"
depends="py3-openssl py3-asn1"
makedepends="py3-setuptools"
-source="$_pkgname-$pkgver.tar.gz::https://github.com/cedadev/$_pkgname/archive/$pkgver.tar.gz"
-
+source="$_pkgname-$pkgver.tar.gz::https://github.com/cedadev/ndg_httpsclient/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
replaces=py-ndg_httpsclient # Backwards compatibility
provides=py-ndg_httpsclient=$pkgver-r$pkgrel # Backwards compatibility
build() {
- cd "$builddir"
python3 setup.py build
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}