aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-prettytable
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-prettytable')
-rw-r--r--community/py3-prettytable/APKBUILD12
1 files changed, 4 insertions, 8 deletions
diff --git a/community/py3-prettytable/APKBUILD b/community/py3-prettytable/APKBUILD
index 5cedbea0a6..a183b42000 100644
--- a/community/py3-prettytable/APKBUILD
+++ b/community/py3-prettytable/APKBUILD
@@ -3,32 +3,28 @@
pkgname=py3-prettytable
_pkgname=prettytable
pkgver=0.7.2
-pkgrel=2
-pkgdesc="A simple Python library for easily displaying tabular data in a visually appealing ASCII table format"
-url="http://code.google.com/p/prettytable/"
+pkgrel=3
+pkgdesc="Python library for easily displaying tabular data"
+url="https://code.google.com/p/prettytable"
arch="noarch"
-license="BSD"
+license="BSD-3-Clause"
depends="python3"
makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/P/PrettyTable/$_pkgname-$pkgver.tar.gz"
-
builddir="$srcdir/$_pkgname-$pkgver"
replaces=py-prettytable # Backwards compatibility
provides=py-prettytable=$pkgver-r$pkgrel # Backwards compatibility
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
python3 setup.py test
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}