aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pygit2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pygit2/APKBUILD')
-rw-r--r--community/py3-pygit2/APKBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/community/py3-pygit2/APKBUILD b/community/py3-pygit2/APKBUILD
index 9f8a21e2aa..c50e586256 100644
--- a/community/py3-pygit2/APKBUILD
+++ b/community/py3-pygit2/APKBUILD
@@ -12,7 +12,9 @@ license="GPL-2.0 WITH GCC-exception-2.0"
depends="py3-cffi py3-six"
makedepends="python3-dev py3-setuptools libgit2-dev"
checkdepends="py3-pytest py3-hypothesis"
-source="https://pypi.io/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz"
+source="https://pypi.io/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz
+ skip-failing-test-on-s390x.patch
+ "
builddir="$srcdir/$_pkgname-$pkgver"
replaces="py-pygit" # Backward compat
@@ -30,4 +32,5 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="33296f95aacbfc3cbce275f84c2025767499738495941408de15ac14f822de132995c05c713b815732dbfc3094edf64351d6240e7201e472b3c47035a7532eff pygit2-1.0.0.tar.gz"
+sha512sums="33296f95aacbfc3cbce275f84c2025767499738495941408de15ac14f822de132995c05c713b815732dbfc3094edf64351d6240e7201e472b3c47035a7532eff pygit2-1.0.0.tar.gz
+1bd1ed146ebfae659c20aa641f795606a32e485fab13a71db12345082a18a9de9f0129d8375ffb6bf8616c906c59d0b25fb440e1f00bcd56e3e10b9aac3363fd skip-failing-test-on-s390x.patch"