aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-rtslib/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-rtslib/APKBUILD')
-rw-r--r--community/py3-rtslib/APKBUILD18
1 files changed, 6 insertions, 12 deletions
diff --git a/community/py3-rtslib/APKBUILD b/community/py3-rtslib/APKBUILD
index 2c0a6fa915..f71c5be740 100644
--- a/community/py3-rtslib/APKBUILD
+++ b/community/py3-rtslib/APKBUILD
@@ -5,28 +5,22 @@ _pkgname=rtslib-fb
pkgver=2.1_p69
_ver=${pkgver/_rc/rc}
_ver=${_ver/_p/.fb}
-pkgrel=1
+pkgrel=2
pkgdesc="Python library that provides an object API to RisingTide Systems generic SCSI Target"
+options="!check" # No testsuite
url="https://github.com/open-iscsi/rtslib-fb"
arch="noarch"
-license="AGPL-3.0"
-depends="python3"
-makedepends="$depends_dev py3-configobj py3-ethtool py3-ipaddr py3-setuptools"
+license="Apache-2.0"
+depends="py3-udev python3 py3-six"
+makedepends="py3-setuptools"
source="https://github.com/open-iscsi/rtslib-fb/archive/v${_ver}.tar.gz"
-options="!check" # no test suite
builddir="$srcdir"/${_pkgname}-${_ver}
-prepare() {
- default_prepare
-}
-
build() {
- cd "$builddir"
- return 0
+ python3 setup.py build
}
package() {
- cd "$builddir"
python3 setup.py install --root="$pkgdir"
# install -D -m644 specs/ib_srpt.spec $pkgdir/var/lib/target/fabric/ib_srpt.spec
# install -D -m644 specs/iscsi.spec $pkgdir/var/lib/target/fabric/iscsi.spec