aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-ruamel.std.pathlib/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-ruamel.std.pathlib/APKBUILD')
-rw-r--r--community/py3-ruamel.std.pathlib/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/py3-ruamel.std.pathlib/APKBUILD b/community/py3-ruamel.std.pathlib/APKBUILD
new file mode 100644
index 0000000000..d78437ea3c
--- /dev/null
+++ b/community/py3-ruamel.std.pathlib/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
+# Contributor: Keith Maxwell <keith.maxwell@gmail.com>
+pkgname=py3-ruamel.std.pathlib
+_pyname=ruamel.std.pathlib
+pkgver=0.6.3
+pkgrel=0
+pkgdesc="improvements over the standard pathlib module and pathlib2 package"
+url=https://bitbucket.org/ruamel/std.pathlib
+arch=noarch
+license=MIT
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest"
+source="$_pyname-$pkgver.tar.gz::https://bitbucket.org/ruamel/std.pathlib/get/$pkgver.tar.gz"
+# 79fff2a1baf7ae44c46415b5fac653cf4a7db9d2 0.6.3
+builddir="$srcdir/ruamel-std.pathlib-79fff2a1baf7"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ PYTHONPATH=build/lib python3 -m pytest
+}
+
+package() {
+ cd "$builddir"
+ python3 -m pip install . --prefix=/usr --root="$pkgdir"
+}
+sha512sums="1210d8f7ae77c6358fc857c3ee447b2eb9802eaa31a210804acd74ec23dfd6ac9dec90dd7b21c79dcb4845dff4ad3614dd615c4798d3d7a39cc3a877cb9b63b0 ruamel.std.pathlib-0.6.3.tar.gz"