aboutsummaryrefslogtreecommitdiffstats
path: root/community/ruby-rmagick
diff options
context:
space:
mode:
Diffstat (limited to 'community/ruby-rmagick')
-rw-r--r--community/ruby-rmagick/APKBUILD6
1 files changed, 1 insertions, 5 deletions
diff --git a/community/ruby-rmagick/APKBUILD b/community/ruby-rmagick/APKBUILD
index de7584ebc2..d902ab7aaa 100644
--- a/community/ruby-rmagick/APKBUILD
+++ b/community/ruby-rmagick/APKBUILD
@@ -7,7 +7,7 @@ _pkgver=${pkgver//./-}
pkgrel=1
pkgdesc="Ruby bindings for ImageMagick"
url="https://rmagick.github.io/"
-arch="all"
+arch="all !s390x"
license="MIT"
depends="ghostscript-fonts"
checkdepends="ruby-rake ruby-rspec"
@@ -18,8 +18,6 @@ source="https://github.com/rmagick/rmagick/archive/RMagick_$_pkgver.tar.gz
builddir="$srcdir/rmagick-RMagick_$_pkgver"
build() {
- cd "$builddir"
-
gem build $_gemname.gemspec
gem install --local \
--install-dir dist \
@@ -30,8 +28,6 @@ build() {
}
check() {
- cd "$builddir"
-
GEM_PATH='dist:.gem' rspec
}