aboutsummaryrefslogtreecommitdiffstats
path: root/community/ruby2.1
diff options
context:
space:
mode:
Diffstat (limited to 'community/ruby2.1')
-rw-r--r--community/ruby2.1/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/community/ruby2.1/APKBUILD b/community/ruby2.1/APKBUILD
index 0848b1c86b..412715e0c3 100644
--- a/community/ruby2.1/APKBUILD
+++ b/community/ruby2.1/APKBUILD
@@ -9,7 +9,7 @@ _abiver="$_majorver.0"
pkgrel=0
pkgdesc="An object-oriented language for quick and easy programming"
url="http://www.ruby-lang.org/en/"
-arch="all !aarch64"
+arch="all"
license="Ruby"
depends=""
makedepends="zlib-dev openssl-dev gdbm-dev db-dev readline-dev
@@ -46,6 +46,7 @@ build() {
# In many places aliasing rules are broken; play it safe
# as it's risky with newer compilers to leave it as it is.
export CFLAGS="$CFLAGS -fno-omit-frame-pointer -fno-strict-aliasing"
+ export CPPFLAGS="$CPPFLAGS -fno-omit-frame-pointer -fno-strict-aliasing"
# ruby saves path to install. we want use $PATH
export INSTALL=install