aboutsummaryrefslogtreecommitdiffstats
path: root/community/rust/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/rust/APKBUILD')
-rw-r--r--community/rust/APKBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/community/rust/APKBUILD b/community/rust/APKBUILD
index 06a8e408dc..9af9007825 100644
--- a/community/rust/APKBUILD
+++ b/community/rust/APKBUILD
@@ -128,6 +128,12 @@ build() {
check() {
cd "$builddir"
+ # At this moment lib/rustlib/$CTARGET/lib does not contain a complete
+ # copy of the .so libs from lib (they will be copied there during
+ # `x.py install`). Thus we must set LD_LIBRARY_PATH for tests to work.
+ # This is related to change-rpath-to-rustlib.patch.
+ export LD_LIBRARY_PATH="$builddir/build/$CTARGET/stage2/lib"
+
"$srcdir"/check-rustc "$builddir"/build/$CTARGET/stage2/bin/rustc
# XXX: There's some problem with these tests, we will figure it out later.
@@ -138,6 +144,8 @@ check() {
msg "Running tests for cargo..."
CFG_DISABLE_CROSS_TESTS=1 ./x.py test --no-fail-fast src/tools/cargo
+
+ unset LD_LIBRARY_PATH
}
package() {