aboutsummaryrefslogtreecommitdiffstats
path: root/community/safekeep/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/safekeep/APKBUILD')
-rw-r--r--community/safekeep/APKBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/community/safekeep/APKBUILD b/community/safekeep/APKBUILD
new file mode 100644
index 0000000000..17f044d7b2
--- /dev/null
+++ b/community/safekeep/APKBUILD
@@ -0,0 +1,53 @@
+# Contributor: Henrik Riomar <henrik.riomar@gmail.com>
+# Maintainer: Henrik Riomar <henrik.riomar@gmail.com>
+pkgname=safekeep
+pkgver=1.4.4
+pkgrel=1
+pkgdesc="SafeKeep backup system"
+url="https://github.com/dimipaun/safekeep"
+arch="noarch"
+license="GPL2"
+depends="openssh-client python2 rdiff-backup util-linux"
+makedepends="asciidoc libxml2-utils xmlto"
+install="$pkgname-server.post-install"
+subpackages="$pkgname-doc $pkgname-client $pkgname-server"
+source="$pkgname-$pkgver.tar.gz::https://github.com/dimipaun/$pkgname/archive/$pkgver.tar.gz
+ 0001-ssh.strict_hostkey_checking-configurable.patch
+ "
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make man || return 1
+ # ionice from util-linux is in /usr/bin (busybox in /bin)
+ sed -i 's|PATH=/sbin:/bin:/usr/sbin:/usr/bin|PATH=/sbin:/usr/sbin:/usr/bin:/bin|' safekeep.cron || return 1
+}
+
+check() {
+ cd "$builddir"
+ PATH="$PATH:." make check || return 1
+}
+
+client() {
+ pkgdesc="SafeKeep backup system - client"
+ depends="$pkgname"
+ mkdir -p "$subpkgdir"
+ # just a meta package
+}
+
+server() {
+ pkgdesc="SafeKeep backup system - server"
+ depends="$pkgname"
+ mkdir -p "$subpkgdir"
+ mv "$pkgdir"/etc "$subpkgdir"/etc || return 1
+ mkdir "$subpkgdir"/etc/periodic || return 1
+ mv "$subpkgdir"/etc/cron.daily "$subpkgdir"/etc/periodic/daily || return 1
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir" || return 1
+}
+
+sha512sums="2afdf6784ef2033032978554bc4b8703be86b5dde92795f1b7efe0099fc4cd35d215bc390e9b9ee3b3e396435ab1168a81dad1c7051861fb584a31749e63c68d safekeep-1.4.4.tar.gz
+c4576c6aad11b70b3e3fbd43a726dcc9f41e6a607281178f30605ff0812833e09efc97d46dda68c89d6e1586e9dc01a74f38484c625f64d084f11f4d806e1e25 0001-ssh.strict_hostkey_checking-configurable.patch"