aboutsummaryrefslogtreecommitdiffstats
path: root/community/sdl_image/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/sdl_image/APKBUILD')
-rw-r--r--community/sdl_image/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/community/sdl_image/APKBUILD b/community/sdl_image/APKBUILD
new file mode 100644
index 0000000000..7963cc8e0e
--- /dev/null
+++ b/community/sdl_image/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Carlo Landmeter
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=sdl_image
+pkgver=1.2.12
+pkgrel=5
+pkgdesc="A simple library to load images of various formats as SDL surfaces"
+url="http://www.libsdl.org/projects/SDL_image/"
+arch="all"
+options="!check" # No test suite.
+license="Zlib"
+makedepends="sdl-dev libpng-dev libjpeg-turbo-dev libwebp-dev tiff-dev zlib-dev"
+subpackages="$pkgname-dev"
+source="https://www.libsdl.org/projects/SDL_image/release/SDL_image-$pkgver.tar.gz
+ CVE-2019-13616.patch
+ "
+
+# secfixes:
+# 1.2.12-r5:
+# - CVE-2019-13616
+
+builddir="$srcdir"/SDL_image-$pkgver
+prepare() {
+ update_config_sub
+ default_prepare
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="0e71b280abc2a7f15755e4480a3c1b52d41f9f8b0c9216a6f5bd9fc0e939456fb5d6c10419e1d1904785783f9a1891ead278c03e88b0466fecc6871c3ca40136 SDL_image-1.2.12.tar.gz
+0ae144202435ad35e5ff6ae6b73592cd8ef68dba2704e09ba22f2b9e9d98f547f2ead28327be0594897f2165d2bf5c26f07e8ef72760527e8d9e4e593e8e5f60 CVE-2019-13616.patch"