aboutsummaryrefslogtreecommitdiffstats
path: root/community/shadow/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/shadow/APKBUILD')
-rw-r--r--community/shadow/APKBUILD96
1 files changed, 96 insertions, 0 deletions
diff --git a/community/shadow/APKBUILD b/community/shadow/APKBUILD
new file mode 100644
index 0000000000..c5ac99edb4
--- /dev/null
+++ b/community/shadow/APKBUILD
@@ -0,0 +1,96 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+pkgname=shadow
+pkgver=4.2.1
+pkgrel=6
+pkgdesc="PAM-using login and passwd utilities (usermod, useradd, ...)"
+url="http://pkg-shadow.alioth.debian.org/"
+arch="all"
+license="GPL"
+depends=""
+makedepends="linux-pam-dev"
+subpackages="$pkgname-doc $pkgname-dbg $pkgname-uidmap"
+source="http://pkg-shadow.alioth.debian.org/releases/shadow-$pkgver.tar.xz
+ login.pamd
+ dots-in-usernames.patch
+ cross-size-checks.patch
+ verbose-error-when-uid-doesnt-match.patch
+ "
+options="suid"
+builddir="$srcdir/shadow-$pkgver"
+
+build() {
+ cd "$builddir"
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-nls \
+ --with-libpam \
+ --without-audit \
+ --without-selinux \
+ --without-acl \
+ --without-attr \
+ --without-tcb \
+ --without-nscd \
+ --without-group-name-max-length \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+
+ make DESTDIR="$pkgdir" install || return 1
+
+ # Do not install these pam.d files they are broken and outdated.
+ # nologin is provided by util-linux.
+ rm "$pkgdir"/etc/pam.d/* \
+ "$pkgdir"/sbin/nologin \
+ || return 1
+
+ # However, install our own for login.
+ cp "$srcdir"/login.pamd "$pkgdir"/etc/pam.d/login || return 1
+
+ # /etc/login.defs is not very useful - replace it with a blank file.
+ rm "$pkgdir"/etc/login.defs
+ touch "$pkgdir"/etc/login.defs
+
+ # Avoid conflict with man-pages.
+ rm "$pkgdir"/usr/share/man/man3/getspnam.3* \
+ "$pkgdir"/usr/share/man/man5/passwd.5* || return 1
+}
+
+uidmap() {
+ pkgdesc="Utilities for using subordinate UIDs and GIDs"
+
+ mkdir -p "$subpkgdir"
+ cd "$subpkgdir"
+
+ mkdir -p usr/bin
+ mv "$pkgdir"/usr/bin/new*idmap usr/bin/ || return 1
+ chmod 4711 usr/bin/new*idmap || return 1
+
+ # Used e.g. for unprivileged LXC containers.
+ mkdir etc
+ touch etc/subuid etc/subgid
+}
+
+md5sums="2bfafe7d4962682d31b5eba65dba4fc8 shadow-4.2.1.tar.xz
+72dfc077a61ab7163e312640cc98bba8 login.pamd
+f5fe3d7351d5e4046588b652c482c170 dots-in-usernames.patch
+75bc0cafb44aa86075d2ec056816cc3e cross-size-checks.patch
+6d938a758cba620dde3b9e4ce6e87703 verbose-error-when-uid-doesnt-match.patch"
+sha256sums="3b0893d1476766868cd88920f4f1231c4795652aa407569faff802bcda0f3d41 shadow-4.2.1.tar.xz
+c0d0f2f77133b0663c5a578afeba45d5a9c703ff6f3f6aba3727dfe01877dac0 login.pamd
+ee58c622d1e8283dc4b17e93cc5e68f4ea4336654ebcfb48e46e0efaa864b77f dots-in-usernames.patch
+fc3e32ddfc8eeb284412e8df7ad045ad27b742f5ee733db1a0bc14c97480e013 cross-size-checks.patch
+7d9156d39afa3a937fc64130b1bfe0ddc1dd593caa629f29410ebbf84c258568 verbose-error-when-uid-doesnt-match.patch"
+sha512sums="7a14bf8e08126f0402e37b6e4c559615ced7cf829e39156d929ed05cd8813de48a77ff1f7f6fe707da04cf662a2e9e84c22d63d88dd1ed13f935fde594db95f0 shadow-4.2.1.tar.xz
+46a6f83f3698e101b58b8682852da749619412f75dfa85cecad03d0847f6c3dc452d984510db7094220e4570a0565b83b0556e16198ad894a3ec84b3e513d58d login.pamd
+745eea04c054226feba165b635dbb8570b8a04537d41e914400a4c54633c3a9cf350da0aabfec754fb8cf3e58fc1c8cf597b895506312f19469071760c11f31d dots-in-usernames.patch
+c46760254439176babeef24d93900914092655af3a48f54385adf6ef5a3af76799fb7e96083acd27853d6ab6d7392543dbaf70bb26f164519e92f677da7851a4 cross-size-checks.patch
+1b3513772a7a0294b587723213e4464cc5a1a42ae6a79e9b9f9ea20083684a21d81e362f44d87ce2e6de2daf396d8422b39019923c0b0cbb44fa4c4c24613c0c verbose-error-when-uid-doesnt-match.patch"