aboutsummaryrefslogtreecommitdiffstats
path: root/community/slim/no-slimlock.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/slim/no-slimlock.patch')
-rw-r--r--community/slim/no-slimlock.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/community/slim/no-slimlock.patch b/community/slim/no-slimlock.patch
new file mode 100644
index 0000000000..1c728206e4
--- /dev/null
+++ b/community/slim/no-slimlock.patch
@@ -0,0 +1,16 @@
+Fixes building without PAM
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 9892c1d..eb1608b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -222,7 +222,9 @@ endif(BUILD_SLIMLOCK)
+ ####### install
+ # slim
+ install(TARGETS slim RUNTIME DESTINATION bin)
+-install(TARGETS slimlock RUNTIME DESTINATION bin)
++if(BUILD_SLIMLOCK)
++ install(TARGETS slimlock RUNTIME DESTINATION bin)
++endif(BUILD_SLIMLOCK)
+
+ if (BUILD_SHARED_LIBS)
+ set_target_properties(libslim PROPERTIES