aboutsummaryrefslogtreecommitdiffstats
path: root/community/sngrep/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/sngrep/APKBUILD')
-rw-r--r--community/sngrep/APKBUILD24
1 files changed, 9 insertions, 15 deletions
diff --git a/community/sngrep/APKBUILD b/community/sngrep/APKBUILD
index c46b434ecb..518bbed124 100644
--- a/community/sngrep/APKBUILD
+++ b/community/sngrep/APKBUILD
@@ -8,34 +8,28 @@ url="https://github.com/irontec/sngrep"
arch="all"
license="GPL"
depends="sed"
-depends_dev=""
-makedepends="$depends_dev autoconf automake ncurses-dev libpcap-dev pcre-dev libressl-dev"
-install=""
+makedepends="autoconf automake ncurses-dev libpcap-dev pcre-dev libressl-dev"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.zip::https://github.com/irontec/$pkgname/archive/v$pkgver.zip"
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+builddir="$srcdir"/$pkgname-$pkgver
+
+check() {
+ cd "$builddir"
+ make check
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./bootstrap.sh
./configure --prefix=/usr \
--with-openssl \
--with-pcre \
--enable-ipv6
- make || return 1
+ make
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir/" install
}