aboutsummaryrefslogtreecommitdiffstats
path: root/community/swayidle/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/swayidle/APKBUILD')
-rw-r--r--community/swayidle/APKBUILD65
1 files changed, 65 insertions, 0 deletions
diff --git a/community/swayidle/APKBUILD b/community/swayidle/APKBUILD
new file mode 100644
index 0000000000..0cd2cb1bc6
--- /dev/null
+++ b/community/swayidle/APKBUILD
@@ -0,0 +1,65 @@
+# Contributor: Henrik Riomar <henrik.riomar@gmail.com>
+# Maintainer: Drew DeVault
+pkgname=swayidle
+pkgver=1.2
+pkgrel=1
+pkgdesc="Idle management daemon for Wayland"
+url="http://swaywm.org"
+arch="all"
+license="MIT"
+options="!check" # no test suite included
+makedepends="
+ meson
+ ninja
+ scdoc
+ wayland-dev
+ wayland-protocols
+ "
+subpackages="
+ $pkgname-doc
+ $pkgname-bash-completion:bashcomp:noarch
+ $pkgname-fish-completion:fishcomp:noarch
+ $pkgname-zsh-completion:zshcomp:noarch
+ "
+source="$pkgname-$pkgver.tar.gz::https://github.com/swaywm/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ meson build --prefix /usr
+ ninja -C build
+}
+
+package() {
+ cd "$builddir"
+ DESTDIR="$pkgdir" ninja -C build install
+}
+
+bashcomp() {
+ depends=""
+ pkgdesc="Bash completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+
+ mkdir -p "$subpkgdir"/usr/share/
+ mv "$pkgdir"/usr/share/bash-completion "$subpkgdir"/usr/share/
+}
+
+fishcomp() {
+ depends=""
+ pkgdesc="Fish completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel fish"
+
+ mkdir -p "$subpkgdir"/usr/share/fish
+ mv "$pkgdir"/usr/share/fish/completions "$subpkgdir"/usr/share/fish
+}
+
+zshcomp() {
+ depends=""
+ pkgdesc="Zsh completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel zsh"
+
+ mkdir -p "$subpkgdir"/usr/share/zsh
+ mv "$pkgdir"/usr/share/zsh/site-functions "$subpkgdir"/usr/share/zsh
+}
+
+sha512sums="2539e80a45163bb3e76f7b41f6fd6a1d73d194b7e466f63178b5087d05470fceafba38a26d592a534a01b992a2c0cf0f8fb83805cdf41ee956fea5136cc8fe89 swayidle-1.2.tar.gz"