aboutsummaryrefslogtreecommitdiffstats
path: root/community/syndication/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/syndication/APKBUILD')
-rw-r--r--community/syndication/APKBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/community/syndication/APKBUILD b/community/syndication/APKBUILD
index 815da36b9d..958d3da465 100644
--- a/community/syndication/APKBUILD
+++ b/community/syndication/APKBUILD
@@ -1,19 +1,26 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=syndication
-pkgver=5.62.0
+pkgver=5.63.0
pkgrel=0
pkgdesc="An RSS/Atom parser library"
arch="all"
url="https://community.kde.org/Frameworks"
-license="LGPL-2.0-or-later AND BSD-Clause-3"
+license="LGPL-2.0-or-later AND BSD-3-Clause"
depends_dev="qt5-qtbase-dev kcodecs-dev"
makedepends="$depends_dev extra-cmake-modules doxygen graphviz qt5-qttools-dev"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/syndication-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc"
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
@@ -22,10 +29,12 @@ build() {
}
check() {
+ cd "$builddir"/build
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}
-sha512sums="ef1a01596a577015a1fbe5e26d361b79c04d26d31069de15a7e0a6fc2c1d159cc86648032800ffad227517ee6d64b3b34e8117a130b35292b37bc3ebe2fe6076 syndication-5.62.0.tar.xz"
+sha512sums="a9a89e570b22812d8bfd4814e072908da81d39e54e06881d2835883d502f5e7f8f315c52234f84b4b29a61b911d482f84245ed016592410d2c544c0acbef6a86 syndication-5.63.0.tar.xz"