aboutsummaryrefslogtreecommitdiffstats
path: root/community/syndication
diff options
context:
space:
mode:
Diffstat (limited to 'community/syndication')
-rw-r--r--community/syndication/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/syndication/APKBUILD b/community/syndication/APKBUILD
new file mode 100644
index 0000000000..697fe511c8
--- /dev/null
+++ b/community/syndication/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=syndication
+pkgver=5.60.0
+pkgrel=0
+pkgdesc="An RSS/Atom parser library"
+arch="all"
+url="https://community.kde.org/Frameworks"
+license="LGPL-2.0-or-later AND BSD-Clause-3"
+depends_dev="qt5-qtbase-dev kcodecs-dev"
+makedepends="$depends_dev extra-cmake-modules doxygen graphviz qt5-qttools-dev"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-doc"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_QCH=ON
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+sha512sums="39ef7246f9133af3c1dae87790a6827a7634fb81eb691995b78eb1b3bdc1db701f2d664360931ce0d671cef30db0cf09029ef00ab55c0d9307fa11eb51f18cca syndication-5.60.0.tar.xz"