aboutsummaryrefslogtreecommitdiffstats
path: root/community/syntax-highlighting/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/syntax-highlighting/APKBUILD')
-rw-r--r--community/syntax-highlighting/APKBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/community/syntax-highlighting/APKBUILD b/community/syntax-highlighting/APKBUILD
index 51518d6436..de075306e7 100644
--- a/community/syntax-highlighting/APKBUILD
+++ b/community/syntax-highlighting/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=syntax-highlighting
-pkgver=5.62.0
+pkgver=5.63.0
pkgrel=0
pkgdesc="Syntax highlighting engine for structured text and code"
arch="all"
@@ -12,8 +12,15 @@ makedepends="$depends_dev extra-cmake-modules qt5-qttools-dev doxygen"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/syntax-highlighting-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_LIBDIR=lib \
@@ -22,10 +29,12 @@ build() {
}
check() {
+ cd "$builddir"/build
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}
-sha512sums="c9df17b652c23370b9315a79ce0f46b3392a576505dc080f5813878c7e7e7e492e763fb94b3fad5ea98a7f1b54e32354401d66ad55e42973a1d0e8a3d091202d syntax-highlighting-5.62.0.tar.xz"
+sha512sums="e696c5e7f1dac0bd088fd0b4140fd531e027c185b49b663f3e1e7296a36b31425d4d65f126ee99aa6a42c2c12cc660ccbf0e120ea08960c926a72f7c6b772d26 syntax-highlighting-5.63.0.tar.xz"