aboutsummaryrefslogtreecommitdiffstats
path: root/community/terraform
diff options
context:
space:
mode:
Diffstat (limited to 'community/terraform')
-rw-r--r--community/terraform/APKBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/community/terraform/APKBUILD b/community/terraform/APKBUILD
index 1109b7e17e..9423209220 100644
--- a/community/terraform/APKBUILD
+++ b/community/terraform/APKBUILD
@@ -1,9 +1,10 @@
# Contributor: Thomas Boerger <thomas@webhippie.de>
# Contributor: Gennady Feldman <gena01@gmail.com>
+# Contributor: Sergii Sadovyi <serg.sadovoi@gmail.com>
# Maintainer: Thomas Boerger <thomas@webhippie.de>
pkgname=terraform
pkgver=0.10.8
-pkgrel=0
+pkgrel=1
pkgdesc="Building, changing, and combining infrastructure safely and efficiently"
url="https://www.terraform.io/"
arch="all !armhf"
@@ -20,8 +21,14 @@ prepare() {
build() {
cd "$builddir"
- export GOPATH="$srcdir"
- go build -v -o bin/$pkgname
+ GOPATH="$srcdir" go build -v -o bin/$pkgname \
+ -ldflags "-X main.GitCommit=v$pkgver -X github.com/hashicorp/terraform/version.Prerelease= -s -w"
+}
+
+check() {
+ cd "$builddir"
+ GOPATH="$srcdir" go test
+ bin/$pkgname -v
}
package() {