aboutsummaryrefslogtreecommitdiffstats
path: root/community/ttf-hack
diff options
context:
space:
mode:
Diffstat (limited to 'community/ttf-hack')
-rw-r--r--community/ttf-hack/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/community/ttf-hack/APKBUILD b/community/ttf-hack/APKBUILD
new file mode 100644
index 0000000000..2aa04167b9
--- /dev/null
+++ b/community/ttf-hack/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Ivan Tham <pickfire@riseup.net>
+# Maintainer: Ivan Tham <pickfire@riseup.net>
+pkgname=ttf-hack
+pkgver=3.003
+pkgrel=1
+pkgdesc="A typeface designed for source code"
+url="https://sourcefoundry.org/hack/"
+arch="noarch"
+options="!check"
+license="MIT"
+depends="fontconfig mkfontscale"
+source="https://github.com/source-foundry/Hack/releases/download/v$pkgver/Hack-v$pkgver-ttf.tar.xz"
+
+unpack() {
+ mkdir -p "$builddir"
+ busybox tar -Jxvf "$srcdir"/Hack-v$pkgver-ttf.tar.xz \
+ -C "$builddir" > /dev/null
+}
+
+package() {
+ mkdir -p "$pkgdir"/usr/share/fonts/$pkgname
+ install -m644 *.ttf "$pkgdir"/usr/share/fonts/$pkgname
+}
+
+sha512sums="d6480957ef77b0e117a564b76e7b8b041a28cfc89441d394a27e2a1b230cae7a67c0b9f3cbe6aab48c5d2cc832b0ea653017a3b925db1d0cc2885e02eab9a81d Hack-v3.003-ttf.tar.xz"