aboutsummaryrefslogtreecommitdiffstats
path: root/community/ttf-roboto-mono
diff options
context:
space:
mode:
Diffstat (limited to 'community/ttf-roboto-mono')
-rw-r--r--community/ttf-roboto-mono/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/community/ttf-roboto-mono/APKBUILD b/community/ttf-roboto-mono/APKBUILD
new file mode 100644
index 0000000000..fa755ae880
--- /dev/null
+++ b/community/ttf-roboto-mono/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=ttf-roboto-mono
+pkgver=2.002
+pkgrel=0
+_commit=5338537ef835a3d9ccf8faf386399f13a30605e2
+pkgdesc="Monospaced addition to the Roboto type family"
+options="!check" # No testsuite
+url="https://fonts.google.com/specimen/Roboto+Mono"
+arch="noarch"
+license="Apache-2.0"
+source="
+ https://github.com/google/fonts/raw/$_commit/apache/robotomono/RobotoMono-Bold.ttf
+ https://github.com/google/fonts/raw/$_commit/apache/robotomono/RobotoMono-BoldItalic.ttf
+ https://github.com/google/fonts/raw/$_commit/apache/robotomono/RobotoMono-Italic.ttf
+ https://github.com/google/fonts/raw/$_commit/apache/robotomono/RobotoMono-Light.ttf
+ https://github.com/google/fonts/raw/$_commit/apache/robotomono/RobotoMono-LightItalic.ttf
+ https://github.com/google/fonts/raw/$_commit/apache/robotomono/RobotoMono-Medium.ttf
+ https://github.com/google/fonts/raw/$_commit/apache/robotomono/RobotoMono-MediumItalic.ttf
+ https://github.com/google/fonts/raw/$_commit/apache/robotomono/RobotoMono-Regular.ttf
+ https://github.com/google/fonts/raw/$_commit/apache/robotomono/RobotoMono-Thin.ttf
+ https://github.com/google/fonts/raw/$_commit/apache/robotomono/RobotoMono-ThinItalic.ttf
+ "
+builddir="$srcdir/"
+
+package() {
+ install -Dm644 "$srcdir"/*.ttf -t "$pkgdir"/usr/share/fonts/TTF
+}
+
+sha512sums="3ac20d4b9be200ef72b3d5cd828d751f64a7c0c28094e64752c6a28aac293cafdf196297e991f2c99ec0f9496e1ad4e6f3fcb8e088f94d94d5d7dccec0f589cb RobotoMono-Bold.ttf
+d21ecea9884218f60dadeab029a3dce05331a64dd293ed7837b51bbb1cbfeb1f3def80f528a8f9b50d376109aa3feefde6e52d87c99b7b5220ba66a6f225c96c RobotoMono-BoldItalic.ttf
+ee14840d340efb6cd374937344b0932c6cd30c9b7400b8f973588d50ec69ec1bb873accbd791fefc3ed837608433201f423225efcb75b6f8211e5178ffca2f8b RobotoMono-Italic.ttf
+6407228f341ac3adab69ae64a3ed42d6d409c7ace689d5b046ca981bf5e44ee6a37512fdec2d923c8663e19157d6e55d6cd74aac38d8553258283f08485da40e RobotoMono-Light.ttf
+37c286c6fb798f72ff34117f6fad0f6ecb747bac1d9eea4b26bcf273c31004e2aebf75d4910f37c960787aef94463f94ae025d943dbf0fb736937357b31b869a RobotoMono-LightItalic.ttf
+d753f787777f088b92b3617327866d286591a143ddd53667a48dc6671590d68a33c8d4b190527e1330811bfa724fb0a6020688cfba9d60154b50dcf863a65822 RobotoMono-Medium.ttf
+65304bb8e875c338e6627c9b76d5e3b29dbb24157ab99647dfebcaa15ae463a9115f6f67b9b745880ffc287bf0e4946b4e572fcc3c795d501da95e5e86481e68 RobotoMono-MediumItalic.ttf
+fd46f0d1a62eae535a8cff583ce3811770eb2381f9197b27d7b4111fa43987efda5824f6caa26a5616fc08587da9170afcbb8dac428bc0d750fcf4389939698f RobotoMono-Regular.ttf
+d4bc3f968a46ee1c9497fadb7dd0a20194c759ad6d8a089b6724dbeeb76b5e5e9ac297301c7bad28219bdd73485b4b0cdf351717e27f35e82b15bb1b462e6587 RobotoMono-Thin.ttf
+f74886fb7e01ac56377e79232a1ae3988cbb3b9806c051aab036cea68e761a7a4f29b4b7c6faf5be68afa43ed34bd8ef1fc0d7c01fcfeef38c617f566389585e RobotoMono-ThinItalic.ttf"