aboutsummaryrefslogtreecommitdiffstats
path: root/community/uthash
diff options
context:
space:
mode:
Diffstat (limited to 'community/uthash')
-rw-r--r--community/uthash/APKBUILD38
1 files changed, 7 insertions, 31 deletions
diff --git a/community/uthash/APKBUILD b/community/uthash/APKBUILD
index 04493d72d9..03bba64aaa 100644
--- a/community/uthash/APKBUILD
+++ b/community/uthash/APKBUILD
@@ -1,53 +1,29 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=uthash
-pkgver=2.0.2
+pkgver=2.1.0
_sover=0 # based on Fedora package
pkgrel=0
pkgdesc="C macros for hash tables and more"
url="http://troydhanson.github.io/uthash/"
-arch="all"
-license="BSD"
+arch="noarch"
+license="BSD-2-Clause"
depends_dev="$pkgname=$pkgver-r$pkgrel"
checkdepends="perl"
-subpackages="$pkgname-dev libut"
+subpackages="$pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/troydhanson/$pkgname/archive/v$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
-build() {
- cd "$builddir"
-
- CFLAGS="$CFLAGS -fPIC" make -C libut
- gcc -shared $CFLAGS $LDFLAGS -Wl,-soname,libut.so.$_sover \
- -o libut/libut.so.$_sover libut/*.o
-}
+replaces="libut" # Removed package
check() {
- cd "$builddir"
-
make -C tests
make -C tests/threads
- make -C libut/tests
}
package() {
- cd "$builddir"
-
- mkdir -p "$pkgdir"/usr/include \
- "$pkgdir"/usr/lib
+ mkdir -p "$pkgdir"/usr/include
install -m 0644 src/*.h "$pkgdir"/usr/include/
-
- install -m 0644 libut/libut.a "$pkgdir"/usr/lib/
- install -D -m 0755 libut/libut.so.$_sover "$pkgdir"/usr/lib/
- ln -s libut.so.$_sover "$pkgdir"/usr/lib/libut.so
-}
-
-libut() {
- pkgdesc="Library-implementation of utvector"
-
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/libut.so* "$subpkgdir"/usr/lib/
}
-sha512sums="0c2e686eb5a1d6a03a6fa1d42e803fca4e9b60b2d965c635a5a33d487c8d115f1f8155ff99a0e1874b69f6b66c04ea7d8866472a39abe5d1a23ae73f6fa956d7 uthash-2.0.2.tar.gz"
+sha512sums="c8005113a48ec7636715ecec0286a5d9086971a7267947aba9e0ad031b6113a4f38a1fb512d33d6fefb5891635fdd31169ce4d6ab04b938bda612ebbccb3eda0 uthash-2.1.0.tar.gz"