aboutsummaryrefslogtreecommitdiffstats
path: root/community/whois
diff options
context:
space:
mode:
Diffstat (limited to 'community/whois')
-rw-r--r--community/whois/APKBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/community/whois/APKBUILD b/community/whois/APKBUILD
index 831ee21f95..342765c24f 100644
--- a/community/whois/APKBUILD
+++ b/community/whois/APKBUILD
@@ -7,22 +7,21 @@ pkgdesc="Intelligent WHOIS client by Marco d'Itri"
url="http://www.linux.it/~md/software/"
arch="all"
license="GPL2"
-makedepends="$depends_dev perl libidn-dev gettext-dev"
+makedepends="perl libidn-dev gettext-dev"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/rfc1036/$pkgname/archive/v$pkgver.tar.gz
- undefined-libintl.patch
- "
+ undefined-libintl.patch"
+builddir="$srcdir/$pkgname-$pkgver"
-_builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
make CONFIG_FILE="/etc/whois.conf" \
HAVE_LIBIDN=1 HAVE_ICONV=1 \
|| return 1
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make BASEDIR="$pkgdir" install-whois || return 1
install -D -m644 whois.conf "$pkgdir/etc/whois.conf"
}