aboutsummaryrefslogtreecommitdiffstats
path: root/community/wireshark/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/wireshark/APKBUILD')
-rw-r--r--community/wireshark/APKBUILD110
1 files changed, 110 insertions, 0 deletions
diff --git a/community/wireshark/APKBUILD b/community/wireshark/APKBUILD
new file mode 100644
index 0000000000..a183109f87
--- /dev/null
+++ b/community/wireshark/APKBUILD
@@ -0,0 +1,110 @@
+# Contributor: Sergei Lukin <sergej.lukin@gmail.com>
+# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
+# Contributor: Jeremy Thomerson <jeremy@thomersonfamily.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=wireshark
+pkgver=2.2.6
+pkgrel=0
+pkgdesc="A network protocol analyzer - GTK version"
+url="http://www.wireshark.org"
+arch="all"
+license="GPL2+"
+depends=""
+makedepends="bison flex perl-dev glib glib-dev libpcap-dev libcap-dev
+ gtk+3.0-dev c-ares-dev pcre-dev gnutls-dev libgcrypt-dev libressl-dev
+ libnl3-dev qt5-qtbase-dev qt5-qttools-dev bash"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-gtk $pkgname-common tshark"
+source="http://www.wireshark.org/download/src/$pkgname-$pkgver.tar.bz2
+ fix-androiddump.patch
+ "
+
+builddir="$srcdir"/$pkgname-$pkgver
+
+# security fixes:
+# 2.2.5-r0:
+# - CVE-2017-6467
+# - CVE-2017-6468
+# - CVE-2017-6469
+# - CVE-2017-6470
+# - CVE-2017-6471
+# - CVE-2017-6472
+# - CVE-2017-6473
+# - CVE-2017-6474
+# 2.2.4-r1:
+# - CVE-2017-6014
+# 2.0.5-r0:
+# - CVE-2016-6505
+# - CVE-2016-6506
+# - CVE-2016-6508
+# - CVE-2016-6509
+# - CVE-2016-6510
+# - CVE-2016-6511
+# - CVE-2016-6512
+# - CVE-2016-6513
+
+prepare() {
+ cd "$builddir"
+ for i in $source; do
+ case "$i" in
+ *.patch)
+ msg "Applying $i"
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
+}
+
+build() {
+ cd "$builddir"
+ # configure script searches for uic and uic-qt4 but not uic-qt5
+ # we set path so it finds 'uic'
+ export PATH="$PATH:/usr/lib/qt5/bin"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --with-ssl \
+ --with-gnutls \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make -j1 DESTDIR="$pkgdir" install || return 1
+}
+
+common() {
+ local i
+ pkgdesc="network protoccol analyzer - common files"
+ mkdir -p "$subpkgdir"/usr/lib "$subpkgdir"/usr/share \
+ "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/share/wireshark "$subpkgdir"/usr/share/
+ mv "$pkgdir"/usr/lib/* "$subpkgdir"/usr/lib/
+ # move all bins except wireshark
+ for i in "$pkgdir"/usr/bin/*; do
+ case "$i" in
+ */tshark|*/wireshark|*-gtk) continue;;
+ esac
+ mv "$i" "$subpkgdir"/usr/bin/
+ done
+}
+
+tshark() {
+ pkgdesc="network protoccol analyzer - console version"
+ install -d "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/tshark "$subpkgdir"/usr/bin/tshark
+}
+
+gtk() {
+ pkgdesc="wireshark - GTK GUI"
+ install -d "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/wireshark-gtk "$subpkgdir"/usr/bin/
+}
+
+sha512sums="d373254801b2d9ae248ff45be09ac36e1916b832430b8f57271421cbd2113c1ffa914ef23c7a1e704d8d5f666f0d4de5bcd9ef9d3801686a35511a5f2a230f3f wireshark-2.2.6.tar.bz2
+d462e3289c1350a9f712a21d2d1973977e5dd7989f7beff4b71498551174458f572a23f267c83552f088466cb9d2721df2b2eb807514db6ad1e0877dbc87fc6d fix-androiddump.patch"