aboutsummaryrefslogtreecommitdiffstats
path: root/community/xapian-core
diff options
context:
space:
mode:
Diffstat (limited to 'community/xapian-core')
-rw-r--r--community/xapian-core/APKBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/community/xapian-core/APKBUILD b/community/xapian-core/APKBUILD
index 4c6781a185..2af54f2526 100644
--- a/community/xapian-core/APKBUILD
+++ b/community/xapian-core/APKBUILD
@@ -14,18 +14,23 @@ install=""
subpackages="$pkgname-dev $pkgname-doc libxapian"
source="http://oligarchy.co.uk/xapian/$pkgver/$pkgname-$pkgver.tar.xz
timeval-t.patch"
-
builddir="$srcdir"/$pkgname-$pkgver
build() {
cd "$builddir"
- ./configure --prefix=/usr || return 1
- make || return 1
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
libxapian() {