aboutsummaryrefslogtreecommitdiffstats
path: root/community/xfce4-cpugraph-plugin/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/xfce4-cpugraph-plugin/APKBUILD')
-rw-r--r--community/xfce4-cpugraph-plugin/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/community/xfce4-cpugraph-plugin/APKBUILD b/community/xfce4-cpugraph-plugin/APKBUILD
new file mode 100644
index 0000000000..57ddbbf861
--- /dev/null
+++ b/community/xfce4-cpugraph-plugin/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xfce4-cpugraph-plugin
+pkgver=1.0.5
+pkgrel=1
+pkgdesc="CPU monitor for the Xfce panel"
+url="http://goodies.xfce.org/projects/panel-plugins/xfce4-cpugraph-plugin"
+arch="all"
+license="GPL-2.0-or-later"
+depends=""
+makedepends="libxfce4ui-dev xfce4-panel-dev"
+install=""
+subpackages="$pkgname-lang"
+source="http://archive.xfce.org/src/panel-plugins/xfce4-cpugraph-plugin/${pkgver%.*}/xfce4-cpugraph-plugin-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/xfce4-cpugraph-plugin-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ update_config_sub || return 1
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 DESTDIR="$pkgdir" install || return 1
+}
+
+sha512sums="3d1246958dd30638104f14a8b0078e25c05b67b42da953a97cb51d2b04e70d3f1da9d42ca4f4575b7114bce5abc4cb94d598737631536c0575b55d9a391e210a xfce4-cpugraph-plugin-1.0.5.tar.bz2"