aboutsummaryrefslogtreecommitdiffstats
path: root/community/xkcdpass/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/xkcdpass/APKBUILD')
-rw-r--r--community/xkcdpass/APKBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/community/xkcdpass/APKBUILD b/community/xkcdpass/APKBUILD
index f2de7a05cf..120d32ce64 100644
--- a/community/xkcdpass/APKBUILD
+++ b/community/xkcdpass/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=xkcdpass
pkgver=1.16.3
-pkgrel=0
+pkgrel=1
pkgdesc="Generate secure multiword passwords/passphrases"
url="https://github.com/redacted/XKCD-password-generator"
arch="noarch"
@@ -10,13 +10,9 @@ license="BSD-3-Clause"
depends="py3-xkcdpass"
makedepends="python3-dev py3-setuptools"
subpackages="py3-$pkgname:py3"
-source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$pkgname-$pkgver
-
-prepare() {
- cd "$builddir"
- sed -i 's/python/python3/g' tests/test_xkcdpass.py
-}
+source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz
+ python-to-python3.patch"
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
@@ -36,8 +32,10 @@ package() {
py3() {
pkgdesc="Python library for $pkgname"
depends="python3"
+
mkdir -p "$subpkgdir"/usr/lib
mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
}
-sha512sums="cc216244bc1fa75e286369432c9d3dd92ad150a752d8d58bcf461bf2f1eaf535054b8c92259b66217fad0ec1030e53b52429721c8d2b920a23813e9737955fe3 xkcdpass-1.16.3.tar.gz"
+sha512sums="cc216244bc1fa75e286369432c9d3dd92ad150a752d8d58bcf461bf2f1eaf535054b8c92259b66217fad0ec1030e53b52429721c8d2b920a23813e9737955fe3 xkcdpass-1.16.3.tar.gz
+ad0e4973c5622405f4002181c1678e9c71b03fb2833256423007fa2cd7a2068591124c31ff1e091411fe029646bb01c2a4c3b6b2a068e3530e6db57671df9968 python-to-python3.patch"