aboutsummaryrefslogtreecommitdiffstats
path: root/community/yelp-xsl
diff options
context:
space:
mode:
Diffstat (limited to 'community/yelp-xsl')
-rw-r--r--community/yelp-xsl/APKBUILD28
1 files changed, 6 insertions, 22 deletions
diff --git a/community/yelp-xsl/APKBUILD b/community/yelp-xsl/APKBUILD
index 5bcb059a51..b19b74fafa 100644
--- a/community/yelp-xsl/APKBUILD
+++ b/community/yelp-xsl/APKBUILD
@@ -7,35 +7,19 @@ pkgdesc="A collection of programs and data files to help you build,maintain, and
url="https://wiki.gnome.org/Apps/Yelp"
arch="noarch"
license="GPL/LGPL/MIT"
-depends=""
-depends_dev=""
makedepends="intltool libxslt itstool"
-install=""
-subpackages=""
source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
-
-_builddir="$srcdir/$pkgname-$pkgver"
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
- ./configure --prefix=/usr || return 1
- make || return 1
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="${pkgdir}" install || return 1
+ cd "$builddir"
+ make DESTDIR="${pkgdir}" install
}
-md5sums="2332716e6e39125a942bc761a6f94211 yelp-xsl-3.20.1.tar.xz"
-sha256sums="dc61849e5dca473573d32e28c6c4e3cf9c1b6afe241f8c26e29539c415f97ba0 yelp-xsl-3.20.1.tar.xz"
sha512sums="7ea22c3180261917d1a277a9b5023f9b2b22346bc3f55cdb1c61c4ae8f78411da93058b55f99c25c9a1bedad21ffa6c3dc460e1ee98614a84a4efa2c2449baac yelp-xsl-3.20.1.tar.xz"