aboutsummaryrefslogtreecommitdiffstats
path: root/community/youtube-dl
diff options
context:
space:
mode:
Diffstat (limited to 'community/youtube-dl')
-rw-r--r--community/youtube-dl/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/community/youtube-dl/APKBUILD b/community/youtube-dl/APKBUILD
index db20b0c7f2..0cf7e16658 100644
--- a/community/youtube-dl/APKBUILD
+++ b/community/youtube-dl/APKBUILD
@@ -4,12 +4,11 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=youtube-dl
pkgver=2017.11.26
-pkgrel=0
+pkgrel=1
pkgdesc="A small command-line program to download videos from YouTube"
url="http://youtube-dl.org"
arch="noarch"
license="Unlicense"
-options="!check"
depends="python2 py-setuptools ffmpeg"
subpackages="
$pkgname-doc
@@ -25,6 +24,11 @@ prepare() {
sed -i 's|etc/fish/completions|share/fish/completions|' setup.py
}
+check() {
+ cd "$builddir"
+ ./youtube-dl --help > /dev/null
+}
+
package() {
cd "$builddir"
python2 setup.py install --root="$pkgdir/" --optimize=1