aboutsummaryrefslogtreecommitdiffstats
path: root/community/zstd/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/zstd/APKBUILD')
-rw-r--r--community/zstd/APKBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/community/zstd/APKBUILD b/community/zstd/APKBUILD
index 1113f6ffb1..4ab3419833 100644
--- a/community/zstd/APKBUILD
+++ b/community/zstd/APKBUILD
@@ -2,19 +2,20 @@
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=zstd
pkgver=1.3.3
-pkgrel=0
+pkgrel=1
pkgdesc="Zstandard - Fast real-time compression algorithm"
url="http://www.zstd.net"
arch="all !armhf"
license="BSD"
checkdepends="file"
-subpackages="$pkgname-dev $pkgname-doc"
+subpackages="$pkgname-static $pkgname-libs $pkgname-dev $pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/facebook/$pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
- make -j1
+ unset CPPFLAGS
+ make MOREFLAGS="-O2"
}
check() {
@@ -27,4 +28,10 @@ package() {
make PREFIX="/usr" DESTDIR="$pkgdir" install
}
+static() {
+ pkgdesc="zstd static library"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/*.a "$subpkgdir"/usr/lib/
+}
+
sha512sums="72b63f96f65ca987cdc82c24354f7665c7dc3b2563cb0646f355c34bf8f090d8a0759729f8beaba8317272bdab34749f934055707b25cfd69c98a9fdcfbc59ae zstd-1.3.3.tar.gz"