aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/php7/APKBUILD9
-rw-r--r--community/php7/fix-asm-constraints-in-aarch64-multiply-macro.patch31
2 files changed, 5 insertions, 35 deletions
diff --git a/community/php7/APKBUILD b/community/php7/APKBUILD
index e953b09115..32d8744df7 100644
--- a/community/php7/APKBUILD
+++ b/community/php7/APKBUILD
@@ -19,7 +19,7 @@
pkgname=php7
_pkgreal=php
-pkgver=7.1.12
+pkgver=7.1.13
pkgrel=0
_apiver=20160303
_suffix=${pkgname#php}
@@ -89,7 +89,6 @@ source="http://php.net/distributions/$_pkgreal-$pkgver.tar.bz2
disabled-tests.list
install-pear.patch
includedir.patch
- fix-asm-constraints-in-aarch64-multiply-macro.patch
php7-fpm-version-suffix.patch
allow-build-recode-and-imap-together.patch
fix-tests-devserver.patch
@@ -175,6 +174,9 @@ s390x) options="$options !check";;
esac
# secfixes:
+# 7.1.13-r0:
+# - CVE-2018-5711
+# - CVE-2018-5712
# 7.1.11-r0:
# - CVE-2016-1283
# 7.1.7-r0:
@@ -630,14 +632,13 @@ _mv() {
mv $@
}
-sha512sums="5753ccea57e0e4f23321f3a583369c91a747dfc85875f2817c219437e53c1924e25ecba129f35230df2fc35ca1288a31ceaf146815cca54f4c66425388183db5 php-7.1.12.tar.bz2
+sha512sums="dbab037b5e7c60877f46a201e1712000ba14ae2a984d4f4d4e752c6e1b2797b0f67fbb0b10c69fea77e27cc64c27222459a26772c9a51e8c760ceab1433dc60a php-7.1.13.tar.bz2
1c708de82d1086f272f484faf6cf6d087af7c31750cc2550b0b94ed723961b363f28a947b015b2dfc0765caea185a75f5d2c2f2b099c948b65c290924f606e4f php7-fpm.initd
cacce7bf789467ff40647b7319e3760c6c587218720538516e8d400baa75651f72165c4e28056cd0c1dc89efecb4d00d0d7823bed80b29136262c825ce816691 php7-fpm.logrotate
274bd7b0b2b7002fa84c779640af37b59258bb37b05cb7dd5c89452977d71807f628d91b523b5039608376d1f760f3425d165242ca75ee5129b2730e71c4e198 php7-module.conf
f2c980bf296d9db074196372cbb91b4a81138e25c13f15bab4dd19839209e95f6e0225d89e3105bbf99676818440f31f3cff56bb87d8eb58b6b4ebaf99cfe962 disabled-tests.list
f1177cbf6b1f44402f421c3d317aab1a2a40d0b1209c11519c1158df337c8945f3a313d689c939768584f3e4edbe52e8bd6103fb6777462326a9d94e8ab1f505 install-pear.patch
199aecdbd3b4035aabf5379c215f82412d3c98b79a1ee186944e7fe1f0ed6f40789ea30e2355149491de6be34fc66c5e486e2a79a7e41ab2ae18706ef3ffe79b includedir.patch
-d93d3fc015580cf5f75c6cbca4cd980e054b61e1068495da81a7e61f1af2c9ae14f09964c04928ad338142de78e4844aed885b1ad1865282072999fb045c8ad7 fix-asm-constraints-in-aarch64-multiply-macro.patch
a4c35446745ab0ac806de801f0651fc5d2c98cf60063c3c2d3963a84f1c71ef78e09b7650c08e7231be0fdb93c0c255de38894d7f0e4f4c5a190d17f1a6bc476 php7-fpm-version-suffix.patch
f8ecae241a90cbc3e98aa4deb3d5d35ef555f51380e29f4e182a8060dffeb84be74f030a14c6b452668471030d78964f52795ca74275db05543ccad20ef1f2cc allow-build-recode-and-imap-together.patch
01c3c65f153ea92192f2b2694d93a086ffa67c282fe046f877842942692c25666e4154a09aba6c2161f7f2a3b6595f4d79573e9ee74aec774a95f2f9725846f9 fix-tests-devserver.patch"
diff --git a/community/php7/fix-asm-constraints-in-aarch64-multiply-macro.patch b/community/php7/fix-asm-constraints-in-aarch64-multiply-macro.patch
deleted file mode 100644
index 7a210b6e11..0000000000
--- a/community/php7/fix-asm-constraints-in-aarch64-multiply-macro.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 6cbb9f4c247c5361b8c165fbb40b4118d5d7c0e5 Mon Sep 17 00:00:00 2001
-From: Andreas Schwab <schwab@linux-m68k.org>
-Date: Mon, 25 Apr 2016 11:59:14 +0200
-Subject: [PATCH] Fix asm constraints in aarch64 multiply macro
-
-All operands must be register operands and the output operands are early
-clobbered.
-
-See https://bugs.php.net/bug.php?id=70015
----
- Zend/zend_multiply.h | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/Zend/zend_multiply.h b/Zend/zend_multiply.h
-index dfd21f7..651dd43 100644
---- a/Zend/zend_multiply.h
-+++ b/Zend/zend_multiply.h
-@@ -53,8 +53,8 @@
- __asm__("mul %0, %2, %3\n" \
- "smulh %1, %2, %3\n" \
- "sub %1, %1, %0, asr #63\n" \
-- : "=X"(__tmpvar), "=X"(usedval) \
-- : "X"(a), "X"(b)); \
-+ : "=&r"(__tmpvar), "=&r"(usedval) \
-+ : "r"(a), "r"(b)); \
- if (usedval) (dval) = (double) (a) * (double) (b); \
- else (lval) = __tmpvar; \
- } while (0)
---
-2.8.0
-