aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/ocamlbuild/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/community/ocamlbuild/APKBUILD b/community/ocamlbuild/APKBUILD
index 076c905970..ee4e7e69b3 100644
--- a/community/ocamlbuild/APKBUILD
+++ b/community/ocamlbuild/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Anil Madhavapeddy <anil@recoil.org>
pkgname=ocamlbuild
pkgver=0.12.0
-pkgrel=1
+pkgrel=2
pkgdesc="Generic build tool with built-in rules for building OCaml library and programs."
url="https://github.com/ocaml/ocamlbuild"
arch="all !x86 !armhf !s390x" #ocaml not avail on excluded platforms
@@ -25,6 +25,11 @@ package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
+
+ # Keep only native binary.
+ cd "$pkgdir"/usr/bin
+ rm ocamlbuild.byte
+ mv ocamlbuild.native ocamlbuild
}
sha512sums="0755a8410a1e083d344e2389bbff06ae2ad5daaf9b186147fd0d2fa094bdc3a2e8e94e2a1e666a63276d10899274b905535300f47d50e747e86f17cf562abe08 ocamlbuild-0.12.0.tar.gz"