aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/lua-resty-string/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/lua-resty-string/APKBUILD b/community/lua-resty-string/APKBUILD
new file mode 100644
index 0000000000..79cf43fb3a
--- /dev/null
+++ b/community/lua-resty-string/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=lua-resty-string
+pkgver=0.11
+pkgrel=0
+pkgdesc="String functions for OpenResty"
+url="https://github.com/openresty/lua-resty-string"
+arch="noarch"
+license="BSD"
+depends="nginx-mod-http-lua"
+makedepends=""
+checkdepends="perl-utils perl-test-nginx"
+source="$pkgname-$pkgver.tar.gz::https://github.com/openresty/$pkgname/archive/v$pkgver.tar.gz
+ "
+builddir="$srcdir/$pkgname-$pkgver"
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"/usr/share/lua/common
+ make DESTDIR="$pkgdir" LUA_LIB_DIR="/usr/share/lua/common" install
+}
+
+check() {
+ cd "$builddir"
+ #make test LUA_LIB_DIR="$builddir/tmp"
+}
+
+sha512sums="f1357f5c93a1f0d32f358df2b162e3a2c605cc57ad4e72dd0fdb6a2409f678aa8100f4977d37c717121f629dafb59ab5786982e806f165974f514c34289d92da lua-resty-string-0.11.tar.gz"