aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/libtorrent/APKBUILD39
-rw-r--r--community/rtorrent/APKBUILD45
2 files changed, 84 insertions, 0 deletions
diff --git a/community/libtorrent/APKBUILD b/community/libtorrent/APKBUILD
new file mode 100644
index 0000000000..8d088880c7
--- /dev/null
+++ b/community/libtorrent/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
+# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+
+pkgname=libtorrent
+pkgver=0.13.7
+pkgrel=0
+pkgdesc="BitTorrent library written in C++"
+url="http://rakshasa.github.io/rtorrent/"
+arch="all"
+license="GPL"
+makedepends="zlib-dev libsigc++-dev libressl-dev automake autoconf libtool linux-headers"
+subpackages="$pkgname-dev"
+source="http://rtorrent.net/downloads/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+ cd "$builddir"
+ ./autogen.sh
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --disable-debug \
+ --disable-instrumentation
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="7bf3e87dbd19eb4e6806dff8a01c3ec61ea960bbd809d4bcbee96a46e169f97d0baf0fc85ab4a1efbbab07850e9b1060bae46c453ea6c42f5c23f8d921295efb libtorrent-0.13.7.tar.gz"
diff --git a/community/rtorrent/APKBUILD b/community/rtorrent/APKBUILD
new file mode 100644
index 0000000000..c956046ccc
--- /dev/null
+++ b/community/rtorrent/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+
+pkgname=rtorrent
+pkgver=0.9.7
+pkgrel=1
+pkgdesc="Ncurses BitTorrent client based on libTorrent"
+url="http://rakshasa.github.io/rtorrent/"
+license="GPL"
+arch="all"
+makedepends="libsigc++-dev libtorrent-dev curl-dev xmlrpc-c-dev ncurses-dev"
+checkdepends="cppunit-dev"
+subpackages="$pkgname-doc"
+source="http://rtorrent.net/downloads/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --enable-ipv6 \
+ --disable-debug \
+ --with-xmlrpc-c
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 doc/rtorrent.rc "$pkgdir"/usr/share/doc/rtorrent/rtorrent.rc
+}
+
+sha512sums="e663bd8984bcec91868beaf16d215708bdea8872338365ba6a05c9ea830b2aff045257bbc8bd0414d84009ee85852822c97bb073dfb41c21e3b0081ecaeecc00 rtorrent-0.9.7.tar.gz"