aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/openjdk7/APKBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/community/openjdk7/APKBUILD b/community/openjdk7/APKBUILD
index 910e97083e..59e9751033 100644
--- a/community/openjdk7/APKBUILD
+++ b/community/openjdk7/APKBUILD
@@ -6,7 +6,7 @@ _icedteaver=2.6.3
# pkgver is <JDK version>.<JDK update>
# check icedtea JDK when updating
pkgver=7.91.$_icedteaver
-pkgrel=2
+pkgrel=3
pkgdesc="Sun OpenJDK 7 via IcedTea"
url="http://icedtea.classpath.org/"
arch="all"
@@ -124,6 +124,14 @@ build() {
export PATH=$JAVA_HOME/bin:$srcdir/apache-ant-$ANT_VER/bin:$PATH
export DISTRIBUTION_PATCHES=""
+ # Explicitly set the C++ standard as the default has changed on GCC 6+
+ # and disable optimizations that lead to a broken JVM. These options
+ # has been adopted from the Fedora package.
+ export EXTRA_CPP_FLAGS="$CFLAGS -std=gnu++98 -fno-delete-null-pointer-checks -fno-lifetime-dse"
+ # CXXFLAGS doesn't make it to all calls, so we set the C++ standard
+ # version for C too.
+ export EXTRA_CFLAGS="$CXXFLAGS -std=gnu++98 -Wno-error -fno-delete-null-pointer-checks -fno-lifetime-dse"
+
local patch
for patch in $source; do
case $patch in