aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/ospd-netstat/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/ospd-netstat/APKBUILD b/community/ospd-netstat/APKBUILD
new file mode 100644
index 0000000000..4178d1fb1e
--- /dev/null
+++ b/community/ospd-netstat/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=ospd-netstat
+pkgver=1.0b1
+pkgrel=5
+_pkgid=2219
+pkgdesc="OSP server implementation to allow OpenVAS to remotel control nmap port scanner"
+url="http://www.openvas.org/"
+arch="noarch"
+license="GPL"
+depends="python3 ospd"
+makedepends="cmake python3-dev py3-setuptools"
+source="http://wald.intevation.org/frs/download.php/$_pkgid/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+
+
+md5sums="2ca9530e30a49594883a70a97269a6de ospd-netstat-1.0b1.tar.gz"
+sha256sums="a6c5f86adfaa1ee1622581882c9b8773b6079c93285de51a7865c1a44444d54f ospd-netstat-1.0b1.tar.gz"
+sha512sums="f5a439cd0f60073d5d25c4a10743945b8ef7eb041e0364f0ba73d250d0988b90d75f3156464433a7baab116680e3f54be2bb556053b0020177edca008cda0e69 ospd-netstat-1.0b1.tar.gz"