aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/kinfocenter/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/kinfocenter/APKBUILD b/community/kinfocenter/APKBUILD
new file mode 100644
index 0000000000..a455951c15
--- /dev/null
+++ b/community/kinfocenter/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kinfocenter
+pkgver=5.16.5
+pkgrel=0
+pkgdesc="A utility that provides information about a computer system"
+arch="all"
+url="https://www.kde.org/applications/system/kinfocenter/"
+license="(GPL-2.0-only OR GPL-3.0-only) AND (LGPL-2.1-only OR LGPL-3.0-only)"
+makedepends="extra-cmake-modules qt5-qtbase-dev kcompletion-dev kconfig-dev kconfigwidgets-dev kcoreaddons-dev kcrash-dev kdbusaddons-dev kdoctools-dev ki18n-dev kiconthemes-dev kcmutils-dev kio-dev kservice-dev solid-dev kwidgetsaddons-dev kwindowsystem-dev kxmlgui-dev kdeclarative-dev kpackage-dev solid-dev kwayland-dev glu-dev"
+source="https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-doc $pkgname-lang"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="1b98515beac87ff5394c06dd6029a2688db27a900f4c85fd4884d332a20120d553c25b98ae5ccfd7da2e6cbaa866edb84809f49c1c19922f25241acdc9e56832 kinfocenter-5.16.5.tar.xz"