aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/py3-pyrsistent/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/py3-pyrsistent/APKBUILD b/community/py3-pyrsistent/APKBUILD
new file mode 100644
index 0000000000..b5da20e56b
--- /dev/null
+++ b/community/py3-pyrsistent/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-pyrsistent
+pkgver=0.14.11
+pkgrel=1
+pkgdesc="Persistent/Functional/Immutable data structures"
+url="https://github.com/tobgu/pyrsistent"
+arch="all"
+license="MIT"
+depends="py3-six"
+makedepends="py3-setuptools python3-dev"
+checkdepends="py3-hypothesis py3-pytest"
+source="$pkgname-$pkgver.tar.gz::https://github.com/tobgu/pyrsistent/archive/v${pkgver}.tar.gz"
+builddir="$srcdir/pyrsistent-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="8bfea52e15b1921ff9880a6d795cbbcdbee818ef5b95a2807e28269eba8ff578e07c39615e48eb47e867dd6f2bca5d395b7ae99ecd27424edaf6cbe6097b2e5d py3-pyrsistent-0.14.11.tar.gz"